MemoQ server service with Active Directory authentication turned on fails to start with timeout error
Posted by Peter Reynolds, Last modified by Viktor Mochnács on 22 March 2018 04:57 PM

Title: memoQ server service, with Active Directory authentication turned on, fails to start with timeout error

Cause:   

When you have a memoQ server with Active Directory authentication turned on, the memoQ server service startup may fail with a timeout error. It may occur with large Active Directories.

Symptoms:   

When a memoQ server service with Active Directory authentication turned on is starting, it performs some startup checks in the joined domain. For a large Active Directory, it may take longer than the operating system level service starts the timeout (30 seconds by default).

How to fix it: 

Increase the default operating system level service timeout in the registry.

Follow the steps below:

  1. Run regedit.exe.
  2. Locate and select the following subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control.
  3. Locate the ServicesPipeTimeout entry and modify the value that represents the service start timeout in milliseconds.
  4. If the entry is not there create a new DWORD one with ServicesPipeTimeout name and set the desired increased value.
  5. Restart the computer.
  6. Start memoQ server service.
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